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Chapter 13

Building User-Menus

This chapterIn this chapter you will enhance the end-user interface by adding a menubar
to your application.

13.1 Menu management

MenubarsA menubar is displayed as a horizontal bar at the top of a page, and contains
pop-up menus to activate commands. Menus can be opened using point-and-
click actions.

ToolbarsA toolbar is an optional horizontal bar positioned just below the menubar, and
contains a row of bitmap buttons. These buttons provide easy access to the
most frequently used commands.

Pop-up menusA pop-up menu consists of a set of menu items and other pop-up menus. Pop-
up menus are opened from menubars and right-mouse actions.

Menu itemsMenu items represent the commands that are actually executed. They contain
text describing the command plus details of an optional shortcut to activate
the command from the keyboard.

SeparatorsSeparators are used to structure menu items within a pop-up menu. Separa-
tors are visible as horizontal separation lines in pop-up menus or as spaces
between buttons on toolbars (see Figure 13.1).

Default barsBy default, an Aimms page in User mode will contain the menubar and toolbar
as shown in Figure 13.1.

Figure 13.1: The default page menubar and toolbar
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13.2 The Softdrink Planning menubar

Designing for
end-users

In general, you design menubars and toolbars for your end-users to use in User
mode. Developer-specific commands, such as providing access to the model
tree, should not appear on end-user pages.

Using
conventions

When you structure your menubars, you should try to adhere to acceptable
conventions wherever possible. In addition, your end-users will find it easier
if menubars are consistent across pages. A typical example of a convention
is to include an Exit command as the last menu item in the first menu of the
menubar.

Menubar
structure

The menubar structure that you will use in this tutorial contains the following
seven menus:

� the File menu for backups, printing and quitting,
� the Edit menu for performing common edit manipulations,
� the Data menu for storing and retrieving data,
� the Run menu to control the rolling horizon process,
� the Overview menu to provide easy access to the other pages,
� the Window menu to keep track of open windows, and
� the Help menu to provide application-specific help.

The Aimms

Menu Builder
User menus are created and specified using the Aimms Menu Builder. This
tool displays a tree that contains all menubars and toolbars in a hierarchical
fashion. The look and feel of this menu tree is similar to the other tree-based
Aimms tools.

Opening the
Menu Builder

To create the desired menubar structure you should first open the Menu Buil-
der by pressing the Menu Builder button on the Aimms toolbar or by pressing
the Ctrl+F9 key, and open the Default Page Menubar in the menu tree. The
initial menu tree is shown in Figure 13.2.
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Figure 13.2: The Menu Builder with the initial menu tree

Default bars
can help you

The Default Page Menubar and the Default Page Toolbar in the initial menu tree
are read-only. This property is indicated by the disabled icons in the menu
tree. Nevertheless, these bars can be used as a base construct from which you
can start building your own menubars and toolbars. In this tutorial you will
be asked to copy and paste several parts of the Default Page Menubar while
creating your own Softdrink Planning Menubar.

Creating a
menubar

To create your first menubar you should take the following actions:

� select the User Menu Tree,
� press the New Menubar button on the tool bar,
� specify ‘Softdrink Planning Menubar’ as its name, and
� press the Enter key to register this name.

13.2.1 The File menu

Menu contentsFigure 13.3 shows the proposed File menu containing one submenu and five
menu items. The Backup submenu relates to the backup of data, while the
Print menu item prints the contents of the active window. The other menu
items are self-explanatory.
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Figure 13.3: The proposed File menu

Creating the
File menu

To create this File menu you need to perform the following actions:

� select the Softdrink Planning Menubar in the tree,
� double-click on the menubar icon to open this node,
� press the New Menu button ,
� specify ‘&File’ as the name of this new menu, and
� press the Enter key to register the name.

Ampersand
character

The ampersand in the string ‘&File’ will automatically create a shortcut trig-
gered by the Alt-F key combination. The letter following the ampersand will
be underlined in the actual menu (see Figure 13.3). The ampersand can be
placed in front of any character in the string.

Creating the
Backup menu

To create the Backup submenu of the File menu, you should follow these steps:

� select the File menu in the menu tree,
� double-click on the menu icon to open this node,
� press the New Menu button ,
� specify ‘Backup’ as the name of this new menu, and
� press the Enter key to register the name.

The Menu Builder on your screen should resemble Figure 13.4.
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Figure 13.4: The File menu so far

Using duplicate
menus

Duplicating existing menus and menu items offers two main advantages. First
of all, duplication provides a quick and easy way to construct menus: you
do not have to re-enter the corresponding menu actions. Secondly, duplicate
menu items are easier to maintain, since an update of one of them is automat-
ically propagated to all the others.

Duplicating
menu items

All menu items in the File menu will be duplicates of already existing menu
items. Please carry out the following groups of steps relating to various menu
items:

� go to the File-Backups-Data menu of the Default Page Menubar,
� select the two menu items ‘Create’ and ‘Restore’ simultaneously,
� press the Copy button on the toolbar,
� select the Backup menu created previously,
� open it and click on ‘Insert Menu item here’, and
� select the Paste as Duplicate command from the Edit menu.

� press the minus sign in front of the Backup menu, and
� press the Separator button on the toolbar.

� go to the File menu of the Default Page Menubar,
� select the menu items Print Setup and Print simultaneously,
� press the Copy button on the toolbar,
� select the separator you just created, and
� select the Paste as Duplicate command from the Edit menu.

� press the New Separator button on the toolbar.

� go to the File menu of the Default Page Menubar,
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� select the menu item Exit,
� press the Copy button on the toolbar,
� select the separator you just created, and
� select the Paste as Duplicate command from the Edit menu.

The complete File menu should be as shown in Figure 13.5.

Figure 13.5: The complete File menu

13.2.2 The Edit and Data menus

Menu contentsThe Edit and Data menus to be created should be identical to the correspond-
ing menus already in the Default Page Menubar.

Creating the
Edit and Data
menus

To create the Edit and Data menus you should follow these steps:

� go to the Default Page Menubar,
� select the Edit and Data menus simultaneously,
� press the Copy button on the toolbar,
� select the File menu from the Softdrink Planning Menubar,
� make sure it is closed, and
� select the Paste as duplicate command from the Edit menu.

The Softdrink Planning Menubar with the new Edit and Data menus is shown
in Figure 13.6.
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Figure 13.6: The new File and Data menu

13.2.3 The Run menu

Menu contentsThe Run menu will contain commands to control the rolling horizon process.
There are no standard actions, and you will have to create the menu items
plus their actions explicitly. You should first create the three menu items plus
separator, as shown in Figure 13.7 using the following steps:

� select the Data menu from the menu tree,
� close this menu if it is open,
� press the New Menu button ,
� specify ‘&Run’ as the name of this new menu,
� press the Enter key to register the name,
� open it by double clicking on its icon,
� press the New Item button on the toolbar,
� enter ‘Run Next’ (unquoted) as its text,
� press again the New Item button on the toolbar,
� enter ‘Run All’ (unquoted) as its text,
� press the New Separator button on the toolbar,
� press once again the New Item button on the toolbar, and
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� enter ‘Restart’ (unquoted) as its text.

Figure 13.7: The Run menu

Specifying the
first menu
action

Having created the three menu items you now have to specify the commands
that are executed when these menu items are selected. The following steps
specify the command associated with the Run Next menu item:

� select the Run Next menu item,
� press the Properties button on the toolbar,
� press the Actions tab,
� select the ‘Run’ action,
� press the Add button,
� select the ‘Procedure’ option (not the ‘Page Procedure’ option),
� use the Wizard button to select the procedure RollHorizonOnce,
� press the Finish button, and
� press the OK button.

The completed Action tab of the Menu Properties dialog box should be as
shown in Figure 13.8.
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Figure 13.8: The Action tab of the Menu Properties dialog box

Specifying the
remaining two
menu actions

Repeat the above steps to link the procedure RollHorizonToEnd to the Run All
menu item. Then repeat these steps once more to link the procedure MovePlan-
ningIntervalToStartOfCalendar to the Restart menu item.

13.2.4 The Overview menu

Menu contentsThe Overview menu will provide separate menu items to access each of the
five overview pages. You do not need to specify these menu items separately,
you can make use of the page structure in the Page Manager.

Navigation
menus

The New Navigator button allows you to add navigation menus to your ap-
plication. These navigation menus, with menu items and possibly submenus,
all refer to pages. The menus are structured in the same hierarchical fash-
ion as the corresponding pages in the Page Manager. As a result, navigation
menus are automatically updated in Aimms whenever the structure of pages in
the page tree is modified.

Creating the
Overview
menu

To create the complete Overview menu as a navigation menu you should exe-
cute the following steps:

� select the Run menu from the menu tree,
� close this menu if it is open,
� press the New Menu button ,
� specify ‘&Overview’ as the name of the menu,
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� press the Enter key to register the name,
� open the new Overview menu,
� press the New Navigator button on the toolbar,
� specify ‘Overview Pages’ as the name of the menu, and
� press the Enter key to register the name.

The menu tree on your screen should look like the one shown in Figure 13.9.

Figure 13.9: The menu tree so far

Specifying the
navigation
properties

To specify the pages that are to be displayed through the Overview menu you
should perform the following actions:

� select the ‘Overview Pages’ navigation item from the menu tree,
� press the Properties button button on the toolbar,
� select the Navigation tab,
� select ‘Other Page’ as the option within ‘Reference Page’ (see also Fig-

ure 13.10),
� press the Wizard button at the right of the ‘Other Page’ edit field,
� select the Contents page, and
� press the OK button twice.
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Figure 13.10: The completed Navigation tab of the Menu Properties dialog
box

Viewing the
Overview
menu

The resulting Overview menu will look like the one shown in Figure 13.11.

Figure 13.11: The Overview menu

13.2.5 The Window menu

Menu contentsThe Window menu of the Softdrink Planning Menubar will be identical to the
Window menu of the Default Page Menubar.

Duplicating the
Window menu

To duplicate the Window menu from the Default Page Menubar you should per-
form the following actions:

� select the ‘Window’ menu from the Default Page Menubar,
� press the Copy button on the toolbar,
� select Overview menu from the Softdrink Planning Menubar,
� make sure it is closed, and
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� select the Paste as Duplicate command from the Edit menu.

13.2.6 The Help menu

Menu contentsThe contents of the Help menu is shown in Figure 13.12. The first menu item
will open the Aimms Help document. The second menu item will display the
model summary in a PDF viewer. The third menu item will open an ‘About’
dialog box with some application-specific information.

Figure 13.12: The Help menu in the Softdrink Planning Menubar

Creating the
Help menu

By now, you should be able to create the Help menu and its three menu items
on your own. Note that the three menu items should be created from scratch
using the New Item button on the toolbar.

Specifying the
first menu item

Rather than duplicating the first menu item, you are asked to specify the menu
command directly by executing the following actions:

� select the ‘Aimms Help’ menu item,
� press the Properties button on the toolbar,
� press the Actions tab,
� select the ‘Menu Command’ option,
� press the Add button,
� select the ‘Help-Contents and Index’ entry (see Figure 13.13), and
� press the OK button.
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Figure 13.13: The Action tab of the Menu Properties dialog box

Creating a
procedure . . .

To specify the Model Summary menu command you need to declare an aux-
iliary Aimms procedure. To keep your model tree well-organized you should
first create a new model section called Softdrink Planning Menubar underneath
the Scenario Overview section, and then create a procedure ShowModelSummary
inside this section as shown in Figure 13.14. This procedure should have the
following Body attribute:

ShowHelpTopic( "section.3.4", "Tutorial/AIMMS_tutorial_for_professionals.pdf" );

Note that you might need to change the path of the tutorial file that is passed
as the second argument of the function ShowHelpTopic.

Figure 13.14: The Softdrink Planning Menubar section of the model tree
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. . . and
specifying the
second menu
item

You are now ready to link the procedure you have just created to the Model
Summary menu command using the following actions:

� select the ‘Model Summary’ menu item,
� press the Properties button on the toolbar,
� press the Actions tab,
� select the ‘Run’ action,
� press the Add button,
� select the ‘Procedure’ option,
� use the Wizard button to select the procedure ShowModelSummary,
� press the Finish button, and
� press the OK button.

Creating a
dialog page . . .

The last item in the Help menu opens an ‘About’ dialog box providing some
application-specific information such as a version number or copyright infor-
mation. In Aimms you can create a dialog page with the following actions:

� open the Page Manager,
� create a new page with the name ‘About Softdrink Planning’ (see Fig-

ure 13.15),
� open the page in Edit mode,
� open the Page Properties dialog box
� check the ‘Behaves as Dialog’ checkbox underneath ‘Style’,
� press the OK button, and
� resize it to give a reasonably sized dialog box.

Figure 13.15: The page tree with the new About Softdrink Planning dialog page

Providing its
contents . . .

You can insert whatever contents into the About Softdrink Planning dialog
page you want. Figure 13.16 serves as an example, and contains a Close but-
ton, a logo, plus text displaying information about the application. This page
is also available for import from the ‘Pages’ subdirectory. The page import
process was described in the last section of the previous chapter.
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Figure 13.16: The About Softdrink Planning dialog box

. . . and
specifying the
third menu item

Please specify the third menu command by performing the following steps:

� select the About menu item,
� press the Properties button on the toolbar,
� press the Actions tab,
� select ‘Linked Page(s)’ as the action to add,
� press the Add button,
� press the New Page Link button ,
� select the About Softdrink Planning page (see Figure 13.17), and
� press the OK button twice in a row.

Figure 13.17: The Action tab of the menu Item Properties dialog box
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13.2.7 Linking the menubar to pages

Instead of
linking to pages
. . .

You have now completed the specification of the Softdrink Planning Menubar.
Instead of linking this menubar to each individual page, it is much more con-
venient to link it to the Background Color template. This template is shared by
all pages, and menubars on pages are, by default, inherited from templates.

. . . link to a
single template

To link the menu bar to the Background Color template the following actions
are required:

� open the Background Bitmap template in Edit mode,
� open its Page Properties dialog box,
� select the Menu tab,
� select ‘Other’ as the Menu Bar option (see Figure 13.18),
� press the Wizard button on the right of the ‘Other’ edit field,
� select Softdrink Planning Menubar, and
� press the OK button twice.

Figure 13.18: The Menu tab of the Page Properties dialog box
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Viewing the
result

You are now ready to use the newly created menubar. Change the page mode
by pressing the Page User Mode button on the toolbar. The Softdrink
Planning Menubar created in this chapter should appear on all your pages, and
is shown in Figure 13.19.

Figure 13.19: The complete ‘Softdrink Planning Menubar’
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