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1. はじめに 
 1.1 英語環境と日本語環境 

AIMMS には ASCII 版と UNICODE 版があります。 開発環境はどちらの版でも英語ですが、モデルの一部として設定される表示用文字は、UNICODE版に限って日本語を使用できます。もちろん、UNICODE 版に英語を設定することも可能です。 しかしモデルを保存したファイルには、ふたつの版の間の直接の互換性がありません。変換は可能ですが、一部の文字データが消失することがありますので、変換はできるだけ避けてください。 

UNICODE 版で日本語を設定できるのは、“Identifier”などの“Text”項目です。 

 1.2 Mode 
Startup Mode には End-user と Developer があり、プロジェクトに対していずれかを設定します。 そしてプロジェクトの保存後の再起動時に、設定に従ったものが選択され、選択されたものは、起動後には変更できません。 ユーザ用の Page に Page 単位で設定する Mode には、Edit Mode と User Mode のふたつがあります。
Edit Mode では表、グラフの設定や変更ができ、ボタンの実行と値の変更はできません。User Modeではその逆です。 

Startup Mode が End-user の場合、Edit Mode は設定できません。 

 1.3 Solver との接続 
AIMMS には、入力データの操作、計算実行の指示、計算結果の表示の機能がありますが、計算実行の機能はありません。計算実行は別のソフト（solver）が行います。 購入時の契約条件や評価版貸出時の条件によっては、いくつかの solver の小規模版が組込まれています。組込まれた solver のいずれを使うかは、画面上部プルダウンメニューの“Settings” → “Solver Configuration”を選択し、“Set Default”ボタンによって、適当な solver を Default に設定してください。 契約などの条件によっては、AIMMS の外の solver と AIMMS とを接続していただく必要があります。この接続操作は、“Solver Configuration”で、“Add”ボタンによって行ってください。 

 1.4 構成要素と階層構造 
AIMMS には、以下の機能が用意されています。 

Project 最も大きな収納単位です。この中に、以下の全てが収納可能です。 

Library 以下に説明する Model の一部を、全体から切り離して管理する機能です。主に、複数の開発者が分担して作業を行う時に使います。切り離したものを異なる
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フォルダに保存することも可能で、この場合でも、複数のフォルダにまたがってひとつの Project を管理することができます。 

Model 数学的なモデルを記述します。ひとつの Project に複数の Model を定義できますが、ひとつの AIMMS 上には、同時にひとつの Model しか置けません。したがって Model 内では、他の Model は全く見えず、全ては Project に属しているように見えます。 

 Startup Mode が End-user の場合、Model の定義部分は、見えません。 

Section Model に属するフォルダです。 

 Project 直下、または他の Section の下に置けます。 

Declaration これも Model に属するフォルダで、Project の直下、または Section の下に置けます。Declaration の階層は、1 段だけです。  

Identifier Model を構成する最小要素です。定数、変数、式を定義し、Declaration の下に置けます。 

Procedure, Function 

 Model に属する処理手順の設定で、Model 直下または Section の下に置けます。 

 これに Section, Declaration を属させることは可能ですが、乱用すると全体の階層構造を必要以上に複雑にしますので、使用は慎重にしてください。 

Page Model に属するユーザ・インタフェースで、表、グラフ、操作ボタンなどが配置されます。 

Data 変数、定数の値の保存場所で、ひとつのファイルです。Project に属し、値の異なるものを、異なる Case に保存できます。 

 複数のファイルを設定し、使い分けることもできますが、AIMMS に同時に複数の Data file を接続することは、できません。 

 【推奨される Model の階層構造】 

 Model 

  －Procedure, Function  小規模モデルでは、不要 

  －Section  小規模モデルでは、不要 

   －Procedure, Function  中・小規模モデルでは、不要 

   －Section  中・小規模モデルでは、不要 

   －Procedure, Function 

   －Declaration 

    －Identifier 

 

1.5 教材 

AIMMS の開発環境、言語、使用法などを理解するための教材は、AIMMS の開発元からいくつか提供されていますが、それらの使用言語は全て英語です。 

AIMMS をインストールすると、ソフトウェアとともに、以下のものがコンピュータ上にコピーさ
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れます。コンピュータ上にコピーされる文書は、全て PDF 版です。 

 ・Tutorial 

For Beginners と For Professionals のふたつあります。 

 ・例題集 

AIMMS の例題のプジェクト・ファイルを集めたもので、各ファイルには 問題名.aimmspack というファイル名が付いています。 例題は簡単なものから高度なものまであります。各例題は、モデル内容とグラフィック・ユーザインターフェイスの両面で、特定の観点に焦点を当てています。 どのような例題があるかは、この文書最後の「付表 AIMMS Examples 一覧」をご覧ください。 

 ・Reference books 主なものが 4 つあります。 

The User's Guide は開発環境を、The Language Reference はモデリング言語の詳細を、The Function 

Reference は各関数の機能を、そして Optimization Modeling は AIMMS に限定しないモデル構築の一般論を、それぞれ解説しています。 

 以上の他にこの「AIMMS 使用法」など、株式会社オクトーバー・スカイが作った日本語版もあります。 この日本語版「AIMMS 使用法」中の「AIMMS 体験コース」は Tutorial For Beginners を元に、その後の「開発支援機能」と「適用アプリケーションが限られる高度な機能」は Tutorial For Beginners, 

Tutorial For Professionals, The User’s Guide, The Function Reference などを元に作りました。 
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2. AIMMS 体験コース 2.1 コースの概要 次の章から「モデルの実行」の章までは、モデルを作って実行するまでを体験することによって、
AIMMS 全体を理解していただくことを目的としています。 この体験コースは 1 時間程度でも終了できますが、余計に時間がかかっても、気にかかることをできるだけたくさん理解するよう、心がけてください。 

 

2.1.1 コースの範囲 問題の説明とその数学的なモデルの説明を読んだ後で、以下の一連の作業を実行していただきます。 ・AIMMS の中に、新しいプロジェクトを作る。 ・Declaration 中に Identifier（Set（集合）、Parameter、Variable など）を設定する ・データを与える ・データを Case に保存する ・Procedure（実行などの動作指示）を設定する ・以下の機能を載せた Page を設定する 入力値を表示する表とグラフ 結果値を表示する表とグラフ 

Procedure を実行するボタン 評価値の値を表示する欄 ・実行する 

 

2.1.2 問題の表現とモデルでの記述 以下に、ここで取り上げる例題「ビール輸送問題」の定義を示します。 

 ビールを、ある期間に、2 つの工場から 5 つの顧客に、トラックで運ぶ。 各工場には生産量の上限がある。 各顧客の需要量は与えられている。 各工場から各顧客への輸送コスト単価は、与えられている。 制約：輸送量は、顧客の需要を満たし、各工場の生産能力を超えない。 目的：コスト最小の輸送計画を作る。 

 次の表に、この問題のデータを示します。 
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表 2.1 ビール輸送問題のデータ  

 図 2.1 問題の地理的な状態 
 以下に、これから構築する数学モデルで使う記号を示します。    指数指数指数指数    

p 工場 

c 顧客 パラメータパラメータパラメータパラメータ    
Sp 工場 p の供給量 

Dc  顧客 c の需要量 

Upc p から cへの輸送コスト単価 変数変数変数変数    Ｘpc  p から cへの輸送量 Ｚ 総輸送コスト 
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 目的と制約は、以下のように表現されます。 目的＝最小化：目的＝最小化：目的＝最小化：目的＝最小化： 

    制約制約制約制約：：：： 

 

 

2.1.3 結果出力のフォーマット 以下のフォーマットで結果を表示します。 

 

 図 2.2 結果出力のフォーマット   
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2.2 モデルの構築 
2.2.1 新しいモデルの作成 

Windows の“スタート” → AIMMS 3.11 Unicode または 

Windows の“スタート” → すべてのプログラム → AIMMS 3.11 Unicode で、AIMMS 3.11 Unicode を起動してください。ASCII 版の場合は、Unicode を取ってください。 起動後、File → New Project を選択して、以下のダイアログ“New Project”を表示してください。 

 

 このダイアログに上図のような文字を入れて（このとおりである必要はありません）、“OK”ボタンをクリックしてください。 すると、以下のような“Model Explorer”が表示されます。 

 

 

 “Model Explorer”では、“New Project”で設定した“Project Name”の頭に Main が付いたものが表示されます。この状態では、その下位に“Declaration”と“Procedure”（P と書かれた四角）が設定されていますが、それぞれに内容は設定されていません。 ここで、「構成要素と階層構造」の章で述べた制限に従って、Model の構成要素である“Section”、“Declaration”および“Identifier”を設定します。 

 

 “Declaration”の左隣の“＋”をクリックして展開した状態（“＋”が“－”に変わっています）
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で、その“Declaration”を選択し、画面上部ツールバー中 のひとつをクリックすることによって、空の“Identifier”が作られます。これに必要な事項を設定することによって、設定が完成します。 以下に各 Identifier の設定方法を示します。 

 

2.2.2 Set（集合）の設定 

Set によって、要素が固定された集合を表現します。 画面上部ツールバー中の Identifier の中の“S”をクリックしてください。選択できない場合は、“Declaration”をクリックしてから“S”をクリックしてください。 “Declaration”のひとつ下の階層に何かひとつでも設定された後は、“Declaration”の左隣に“＋”または“－”の記号が表示されます。“－”の時は Identifier を選択可能で、“＋”の時はこの記号をクリックすると記号が“－”に変わります。“＋”のクリックは、“Declaration”という文字の左隣の記号 のダブルクリックと同じ意味です。 “S”のクリックによって“Declaration”の 1 階層下に、名前が空の Set が現れますので、名前に
Plants と入力してください。 次に、名前またはその左隣の S をダブルクリックすると、右のペインに、Set（Plants）の詳細設定画面が表示されます。名前またはその左隣の S を右クリックし、表示される選択肢の中から“attributes”を選択しても、同じ画面が表示されます。 

 

 

 ここで、Index に p を設定してください。 

User 表示画面で Plants を別の名前で表示したい場合は、Text に表示用の名前を設定してください。
UNICODE 版では、Text に日本語を使うこともできます。 この画面を終了するには、右上のボタン“Check, commit and close”、“Commit and close”のいずれ
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かクリックしてください。 

 次に同様の操作で、Set（Customers）を設定し、Index に c を設定してください。 その結果、“Model Explorer”の表示は、以下のように変わります。 

 

 

 

2.2.3 Parameter の設定 画面上部ツールバーの Identifier 中の“P”をクリックしてください。 

 

Supply（工場ごとの供給量）、Demannd（顧客ごとの需要量）、および UnitTranportCost（工場から顧客への輸送コスト単価）の 3 つの Parameter を設定します。 

Parameter 名、Index を設定するのは、Set と同じです。 

UnitTranportCost は、工場 p と顧客 c に対する 2次元ですので、Index は（p, c）と設定します。 

 その結果、“Model Explorer”の表示は、以下のように変わります。 
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2.2.4 Variable（変数）の設定 画面上部ツールバーの Identifier 中の“V”をクリックして、Variable（変数）を設定してください。 

 まず、輸送量を表す Variable（UnitTransportCost）を設定してください。この Variable は、工場 p と顧客 c に対する 2次元変数ですので、Index は（p, c）と設定します。 この Variable は独立変数ですので、変数の種類と値の範囲を指定する必要があります。 

 変数の種類は、“Property”の欄を選ぶと以下のダイアログが表示されますので、適当なものを選んで“OK”ボタンをクリックしてください。 

 

 

 

Range の欄を選択すると、以下のダイアログが表示されますので、ここにある候補の中から一つを選んで、“OK”ボタンをクリックしてください。 
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 次に、総コストを表す Variable（TotalTransportCost）を設定してください。 

 

 

 この Variable は従属変数ですので、変数の種類と値の範囲を指定する必要はありませんが、そのかわりに、Definition欄に定義を設定する必要があります。この場合の定義とは、各輸送コスト（単価×輸送量）の全工場と全顧客についての和に等しい、というものです。 この定義は、制約としても設定できますが、モデルの分かりやすさと保守しやすさの観点から、 ここで設定することを勧めます。 

  



 

－ 12 － 
Copyright 2011 by October Sky Co., Ltd., All Right for Japanese Translation Reserved 
Copyright 2011 by Paragon Decision Technology B.V.  All Right for contents Reserved 

2.2.5 Constraint（制約）の設定 画面上部ツールバーの Identifier 中の“C”をクリックして、Constraint（制約）を設定してください。 最初の Constraint は、供給量による制限（SupplyRestriction）で、以下のように設定してください。 

 

 

 次の Constraintは、需要量を満足すること（DemandRequirement）で、以下のように設定してください。 
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2.2.6 評価関数式の設定 左のペインで“ Declaration”の左隣が“－”の状態で をクリックし、画面上部ツールバー中 の“…”をクリックすると、以下のダイアログが表示されます。異なる状態で“…”をクリックすると、異なるダイアログが表示されますので、注意してください。 

 

 

 この中で“Mathematical Program”を選択して“OK”ボタンをクリックし、右のペインに表示される画面に、以下の図のように最適化の条件を設定してください。 名前（Identifier の項）以外の設定は直接記入せず、以下に記した方法で行ってください。 
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Objective を選択する（“Objective”という文字の右隣のボタンをクリックする）と以下のようなダイアログが表示されますので、最適化対象の Variable を選択し、“Finish”ボタンをクリックしてください。 

 

 

 “Direction”を選択すると以下のダイアログが表示されますので、“Minimize”か“Maximize”かいずれかを選択し、“OK”ボタンをクリックしてください。 

 

 

 “Type” を選択すると、計算の種類を選択する以下のダイアログが表示されますので、いずれかを選択し、“OK”ボタンをクリックしてください。 使う Solver によって、使用できるものとできないものがありますし、使用できないものを選択して
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もこの段階で警告は発生しませんので、注意が必要です。 
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2.2.7 Identifier の設定内容確認 画面上部プルダウンメニューの“View”→“Text Representation”→“All”と選択すると、その時選択されている Model 内の全ての Identifier、Procedure、Function の設定内容を、右のペインにテキスト形式で以下のように表示します。 

View → Text Representation → Selected Part(s) と選択すると、その時選択している Identifier、
Procedure、または Functionだけの設定内容を表示します。 
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2.3 データの入力と保存 
2.3.1 Set データの入力 

Identifierリスト中の特定の Set を選択 → 右クリック → “Attributes…”を選択 と進むと、右のペインに、詳細設定 Page が表示されます。 この中の最後の項目がデータの設定で、まず、“Definition”または“Initial Data”を選択してください。 “Initial Data”を選択すると、“User Mode”が設定された Page から要素を削除できますが、追加、変更はできません。削除後の状態は、“User Mode”でも Caseへ保存でき、その Case を呼び出すと保存時の状態に戻ります。 “Definition”を選択すると、“User Mode”では削除もできません。 次に“Definition”、“Initial Data”の右隣にあるボタンをクリックすると、以下のダイアログが表示されます ここで新しく Set の要素名を入力して“＋”ボタンをクリックすると、この要素が追加されます。 

 

 

 下図のように設定済みの要素を選んで“×”ボタンをクリックすると、その要素は削除されます。 

 

 

 “Close”ボタンをクリックすると、以下のダイアログが表示されます。現在のバージョンでは、
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データを変更しない場合でもこのダイアログが表示されます。 

 

 

 変更データの処理方法を選択肢の中から選んで“OK”ボタンをクリックするか、“Cancel”ボタンをクリックして変更データを破棄するか、いずれかを実行してください。 

 

2.3.2 Parameter データの入力 

Identifierリスト中の特定の Parameter を選択 → 右クリック → “Attributes…”を選択 と進むと、右のペインに、詳細設定 Page が表示されます。 “Definition”、“Initial Data”、これらの右隣にあるボタンの機能は、Set とほぼ同じですが、User は“Initial Data”では値の変更が可能、“Definition”では値の変更が不可能、という点だけが Set と異なります。 ここで、“Supply”、“Demand”そして“UnitTransportCost”の値を設定または変更してください。 “Supply”、“Demand”はひとつの Set に対する Parameter なので 1次元の表、“UnitTransportCost”はふたつの Set に対する Parameter なので 2次元の表が表示されます。 
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 “Close”ボタンをクリックすると、設定・変更データ処理方法の確認に関するダイアログ“Insert 

Current Data”が表示されることは、Set の場合と同じです。 

 

2.3.3 データの保存 画面上部プルダウンメニューの“Data” → “Save Case” と進むと、その時のデータを Caseに保存するための、以下のダイアログが表示されます。 なお、Caseは各Modelに属し、1 Modelに対して複数の Caseを定義できます。 

 



 

－ 20 － 
Copyright 2011 by October Sky Co., Ltd., All Right for Japanese Translation Reserved 
Copyright 2011 by Paragon Decision Technology B.V.  All Right for contents Reserved 

 

 新しい Caseを作って保存する場合、Name欄に名前を入れて“Save”ボタンをクリックすると、その時のデータ一式が、指定された Case名で保存されます。 すでに保存された Caseがある場合、中央の大きい欄に既存の Caseが表示されますので、このうちのひとつを選択するとその Case名が Name欄に表示され、この状態で“Save”ボタンをクリックすると、その時のデータがこの Caseに上書きされます。 

 この時、データの種類が“Initial Data”と指定されている Setと Parameterにおいても、変更後の状態が“Initial Data”として保存されます。 
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2.4 起動時に使用する Case の指定 モデル起動時にどの Case のデータを採用するかは、以下の方法で指定します。 画面上部プルダウンメニューの“Settings” → “Project Options…”と進むと、下図のダイアログが表示されます。 

 

 

 左のペインで“Project”→“Start & authorization”を選択し、右のペインで“Startup case”を選択すると、Startup Caseを指定するスペースが表示されます。このスペースの右隣（AIMMSのバージョンによっては左隣のこともあります）のボタンをクリックすると、 下図のダイアログが表示されますので、指定したい Caseを選択して、“Load”（AIMMSのバージョンによっては“OK”のこともあります）ボタンをクリックしてください。 

 



 

－ 22 － 
Copyright 2011 by October Sky Co., Ltd., All Right for Japanese Translation Reserved 
Copyright 2011 by Paragon Decision Technology B.V.  All Right for contents Reserved 

 

 画面は“AIMMS Options”に戻り、“Apply”が選択可能変わっています。ここで“Apply”ボタンをクリックすると、Model起動時に使われる Caseが指定されます。 なお、Case 指定の操作後最初の Model 終了時に Model を保存しないと、次回起動時にこの指定が有効になりません。 
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2.5 モデル実行内容の指定 モデルの実行を指示する Identifier を、以下のように設定します。 まず、“Model Explorer”が表示されていない場合は、「F8」キーをクリックして表示してください。 次に、“Model Explorer”中の“P(Procedure)”→“MainExcution”を選び、右クリックで表示される選択肢の中から“Attributes…”を選択してください。 その結果、下図のダイアログが表示されますので、Body の欄を下図のように設定し、この Identifierを終了してください。 
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2.6 ユーザ用 Page の構築 画面上部ツールバー中の、“Page Manager”ボタン をクリックすると、“Page Manager”が左ペインに表示されます。 

 

 

 さらにツールバー中の“Page”ボタン をクリックすると、名前が空の Page が作られますので、名前を付けてください。 次に、Page 名またはその左隣の“P”を右クリックし、表示された選択肢の中から“Open in Edit Mode”を選択するか、Page 名を選択した状態でツールバー中の“In Edit Mode” をクリックしてください。これによって、Page が“Edit Mode”で開かれます。 

 ここで、“Edit Mode”は開発時、“User Mode”は実行時に使うためのもので、Pageごとに異なるものを設定できます。 

 

Page には、表、グラフなどを配置できます。 

 

2.6.1 表とグラフの書き方 表の形式には、“Table”と“Composite Table”があり、それぞれは単純な表と、リレーショナル・データベース形式の表です。 以下には“Table”の使い方を示しますが、“Composite Table”の使い方も、“Composite Table”特有の項目の設定以外は、“Table”と同じです。 ツールボックス中の“New-Table”（バージョンによっては“Table”）ボタン をクリックし、カーソルを右のペインに移動すると、カーソルが＋字型に変わります。このカーソルを使って、グラフの左上と右下、または右上と左下の位置を決めてください。 グラフの位置が決まると同時に、以下のようなダイアログが表示されます。 
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 ここで右の欄の Identifier から、例えば“UnitTranportCost(p, c)”を選んで、“Next”ボタンをクリックしてください。次に、Index を選択するためのダイアログが表示されますので、妥当なものを選択して“OK”ボタンをクリックしてください。ただし選択した Identifier の Index がひとつの場合、選択の余地はありませんので、すぐに“OK”ボタンをクリックしてください。 これで Page 上に表が表示されます。 

 この表に対して調整や追加を行う場合は、表を左クリックして選択し、次に右クリックして表示される選択肢の中から“Properties…”を選ぶか、表を選択した後でツールバー上の“Properties…”ボタン をクリックするかして、以下のダイアログを表示してください。 
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 ここでは、この表に“Supply(p)”と“Demand(c)”を加えてください。 タブ“Contents”をクリックし、次に“Add..”ボタンをクリックし、追加したい Parameter を選択して、“OK”ボタンをクリックしてください。 その結果、表は以下のように変わります。 

 

 グラフの書き方は、表の書き方と似ています。 用意されたグラフの種類はいくつかありますが、ここでは“Bar Chart”を例に挙げます。 画面上部ツールバー中の“Bar Chart”ボタン を使い、先程の表と同じ Page 上に“Supply(p)”の“Bar Chart”と“Demand(c)”の“Bar Chart”を書くと、この Page は以下のように変わります。 
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 以上には入力値を表とグラフで書く方法を示しましたが、結果も同様に書けます。 まず、工場 p と顧客 c に対する輸送量 Transport(p,c)を、“Table”または“Composite Table”で書いてください。以下には“Composite Table”を使った例を示します。 

 次に、TotalTranportCost を表示する“Table”を設定してください。 

 さらに、Transport を表示する Bar Chart も設定してください。 

Bar Chart を定義した後でこれを選択し、右クリックで表示される選択肢の中から“Properties…”を選択してください。ここで“Bar Chart”タブをクリックすると、以下のダイアログが表示されます。以下には、デフォルトで選択されている“Overlapping”ではなく、“Stacked Bars”を選択した例を示します。 
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2.6.2 Page の完成 起動ボタンは、以下の手順で設定します。 画面上部ツールバー中の“Button” をクリックし、カーソルで位置と大きさを決めると、以下のダイアログが表示されます。 
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 まず、タブ“Button”を選択して、図のようにボタンの表示名称を設定してください。UNICODE版では、ここで日本語が使えます。 

 次にタブ“Actions”を選択して以下のように設定し、“OK”ボタンをクリックしてください。 
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 以上の操作によって、Page 上にボタンが完成します。 

 

Page のタイトル表示は、以下の方法で設定します。 画面上部プルダウンメニューの“Object” → “Text”と進み、カーソルでテキストの位置と大きさを指定すると、以下のダイアログが表示されます。 

 

 

 タブ“Text”を選択し、上図のように Page のタイトル表示の文字列を与えてください。 

UNICODE 版では、日本語が使えます。 

 次にタブ“Font”を選んでください。 
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 ここで既存のものを選択すると、設定済みのフォントが適用されます。“Header”、“Title”などは
FONT の分類に付けた名前ですので、これらが位置や背景色などに影響することはありません。 “Add…”ボタンによって新しい FONT グループを作ることも、“Modify…”ボタンによって既存の FONT グループの設定を変更することもできます。 

 最後に“Apply”ボタンをクリックすると Text 設定が完了、これで Page の全ての設定が終了して、以下のような Page のデザインや機能が決まります。 
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2.7 モデルの実行 ユーザが設定する入力は、Parameter だけです。 その値を開発者が与える方法はすでに述べましたので、ここでは User Mode の Page 上で Parameterの値を修正する方法を示します。 

 

Parameter が表示されているグラフ上で、その値を示す点か線分をドラッグし（下図の左）、変化させたい値まで動かし（下図の右）、ドロップしてください。表示の変化に対応して、保存されている Parameter の値が変化します。 表中の値を書き換えることによって値を修正することも、可能です。 

 

 ⇒  

 次に、計算を実行するボタン（ここでは“Solve Beer Transport”）をクリックしてください。 

variable の値を示すグラフが、下図の左から右のように変わります。 
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 ⇒  

 以上    
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